Set up Gnosis safe via Admin on Mumbai test tx fail and FE state is confused

Hello :wave:

spam wall is blocking me from putting so many links in the post, just remove the spaces when opening them

I attempted to add an owner to gnosis safe on Mumbai, the transaction failed and the ui doesn't seem to recognise the failed tx and reflects a mixture of a success and pending execution state.

:computer: Environment

  • Admin > Gnosis safe > Proposal add owner

:1234: Steps to reproduce

  1. Create a 2/3 Gnosis safe on Mumbai
  2. Create proposal to add an additional signer (2/4)
  3. Approve from one safe owner EOA
  4. Approve and execute from another safe owner EOA


Background: I didn't fully understand the section in the docs related to Safe Transaction Service and so wanted to test it in action to see if there were any differences from the flow I was familiar with on Safe Transaction Service supported .
https:// docs. openzeppelin. com/defender/admin#gnosis-safe
https:// docs. gnosis.i o/safe/docs/tutorial_tx_service_initiate_sign/

The screenshot below highlights the points which are a bit confusing.

  • The status is still seen as executing
  • It now recognised 4 signers when this tx failed and so would still only be 3
  • Its showing 2 approvers of 1

This is the failed tx
https:// mumbai. polygonscan .com /tx/0xe24a8b5f43c4d0d7b919771d1299255c5ea89b21ce3037d9ac1d20b442c48aeb

Tried to find the failed tx message in the gnosis safe gh but maybe I'm looking in the wrong place or the code has changed since but I couldn't seem to find it.

https:// github .com /gnosis/safe-contracts/search?q=Invalid+owner+provided&type=code

Might be related to this :thinking: ... Anyway, the error message thrown in this require statement returns GS026 which corresponds to Invalid owner provided (see

Hey @Denham! I'm seeing two txs sent to the multisig with very little time difference. Right before the tx you link, I can see a 0xd1aa3f774f1a25971c12450467627d990b34135ce5b9277da41e5c4ad4eda6d0 tx which calls addOwnerWithThreshold successfully.

Now, we do have a known issue in Admin where, after you Approve & Execute a proposal, sometimes the Execute button will show, allowing you to send another tx to try to execute the same proposal. This new tx, however, will fail since the previous tx already executed it.

My guess is that you run into this issue, causing you to send two txs, where the first one landed successfully causing the threshold to be properly increased to 4, and the second one failed since it tried to execute an already executed action.

We'll make sure to get that pesky bug fixed as soon as possible!