Error estimating transaction execution to gnosis safe: [object Object]

Hi, everyone!
I'm having an issue trying to approve & execute a proposal through a Gnosis Safe created using the Openzeppelin Defender. While the approve step is working fine, when trying to execute it I get the following error: "Error estimating transaction execution to gnosis safe: [object Object]".
Besides that, in the console I see a lot of errors saying: "Could not find transaction on safe transaction service".

Already tried to reject it and create a new one but I'm having the same issue. Also, I can only go through the approve process of rejection, while the executing one is giving the same error.

Tried to create a new Gnosis Safe and update it on the smart contract, but I keep getting the same error.

Any suggestion about what can cause this issue?

Can you provide all the relevant code (and only the relevant code)?

There's no code at all. I'm using the Openzeppelin Defender platform to approve & execute this proposal after creating it using the defender.proposeUpgrade (@openzeppelin/hardhat-defender). See the attached image.

image (1)

What about other details, such as contract address, contract function being executed, etc?

Sure, thanks for asking.
I can only share the smart contract address and the Gnosis Safe address since there's no contract function being executed. (I'm trying to upgrade it)

Hi @gabrielstoica

Just to confirm, is this issue still present?

Could you please send your tenantId (visible in the right hamburger menu) and the full URL from the proposal overview page (containing the proposal ID), so that we can take a look into this issue?

You can send that data via email to the official Defender support email address (defender-support @



Hi @zeljko,

I've managed to execute the proposal in the end.
Sent all the infos required via email, if you want to look into it just in case.


1 Like

hello gabriel,

I am getting the same error. How did you fix the issue? that would be great if you remember


Hi @rasimsen,

After creating a few more proposals, I've tried to execute the initial one again and it worked. Unfortunately, I don't have any step-by-step error handling process.

Good luck,