Getting "Ledger: Only version 4 of typed data signing is supported"

:computer: Environment
OpenZeppelin Defender 1.0 + Version 2.0
Chrome Version 121.0.6167.184 (Official Build) (arm64)
Rabby Extension Version 121.0.6167.184 (Official Build) (arm64)
Ledger Nano S Plus OS Version 1.1.1
Ledger Ethereum App 1.10.3

I'm using OpenZeppelin Defender 1.0 to manage my protocol contracts and the various admin functions, utilising a MultiSig/Timelock process. So far in the past several months of using it, I've been successfully able to schedule admin actions on contracts behind a MultiSig/Timelock and was able to approve these transactions for schedule with my signers being Ledgers. I utilise Chrome/Rabby wallet extension to connect to OpenZeppelin Defender's app/website. The last time I was successfully able to do this was about a month ago.

I've just tried this process again, but this time I am encountering a "Transaction Rejected -- Ledger: Only version 4 of typed data signing is supported" error on Rabby when I try to approve/sign an action to be scheduled.

I've updated my Ledger's firmware + the Eth app as well, also have blind signing enabled on the ETH app on ledger.

Had googled for some help but can't find any relevant help... any help much much appreciated!

Also just to confirm, in other dapps, I could still sign using the ledger just fine (same chrome browser, rabby wallet extension, etc)

Update: Also tried it via OpenZeppelin Defender Version 2, same issue. Not sure if this could be a Rabby or Chrome issue?

:1234: Code to reproduce

Just tested using Metamask and now it works... :melting_face:

Hi Jeff...I have the same error code using Metamask in Chrome with Nano-S. What did you do to fix the issue?
Thanks in advance!

Hey Maurice,

So it seems like this issue is still persistent by using Rabby.

Currently I will switch to Metamask and it works -- I did not do anything new, really.

If using metamask didn't work for you, I would suggest you to use the latest versions/updates across:

  • Your ledger nano firmware
  • Your ethereum app version on ledger
  • Your metamask browser wallet version
  • Perhaps even your chrome version just to leave no stones unturned

Apologies if I can't be of more help!

That being said, if anyone from Openzeppelin is reading this, I'm honestly not sure if it's a Rabby Wallet issue or a OpenZeppelin Defender issue. As I am able to use Rabby wallet for all other dApp transactions.

Bumping this thread up in hopes that someone from Defender team could take a look as well