Timelock execute problem

Timelock execute problem

on the defender admin website, timelock execute is not working
:computer: Environment

on the defender admin website, when I try to run execute function by selecting "execute" from dropdown list, there is javascript error on console and website is stucking

:1234: Code to reproduce

Hi @Jason1

Thank you for reporting this issue.
We have investigated the cause and are currently in the process of patching this.
We will work towards getting it released as soon as possible.

Apologies for the inconvenience.

Hi @nami
Thanks for your reply.
I have one more question.
When I run one function via timelock, there is also web3 error of "insufficient funds".
Maybe this issue should be fixed soon?

Hi @Jason1

Could you detail the steps you took and perhaps share some screenshots?
Are you receiving the error in MetaMask or in the Defender UI, and what value are you passing to the function?

Hi @nami
I'm attaching the screenshot of the problem.
I'm receiving the error on console and maybe it should be from estimateGas function

Hi @Jason1

Thank you for letting me know. I will look into this and get back to you ASAP.

Hi @Jason1

The issue should now be resolved.


What about "Insufficient funds" issue?
Still it is not working.

Hi @nami
I'm updating the information.
I think the error is from estimateGas function in this parts before run execute function.

When I run manually timelock.execute() using the same params (data, salt, value, no_predessor), it is working fine.
But on the UI (with multisig wallet) there is error from estimateGas function.


1 Like

Hi, I am facing the same problem. Could you please tell me how to execute it manually?

Thank you.

Getting the same error. Running on bsc-testnet

I used the execute function of timelock contract. You can do that in timelock contract's admin action.
And then You can get all necessary params (data, salt, value, predessor) from the chrome debugging using breakpoint on the above screenshot's code part.

1 Like

Hi @nami
Hove you got a chance to see this problem?

Hi @Jason1,

I have been able to replicate the issue and a patch is in the pipeline. We're in the process of reviewing and testing before we release it to production.

Hi, Thank you for your reply. It is a bit difficult for me to find data, salt, value, predecessor etc., so hope that the OpenZeppelin team provides a solution ASAP.

@CuriosCrew @Jason1 @CryptoDev

The hotfix has been applied. Please try again and let me know if you run into any more issues.

Wow, Great Thanks @nami