Proposals with errors are neither executed nor rejected

Proposals made by ignoring warnings will not be executed, rejected, or archived. As a result, all proposals cannot be processed later.

:computer: Environment
OpenZepplin Defender Admin
Ropsten (Probably the same on other networks)

I made an upgrade proposal using the API, but I accidentally made it run for proxy instead of proxyAdmin.
There was a warning, but I ignored it and approve it, but when I finally try to execute it, it fails with an 'execution reverted' error. I tried to reject it, but there was no response even after receiving the signature from metamask.

Here is a link that is stuck.

I used a gnosis safe multisig wallet, but this proposal cannot be processed, so the proposal that was proposed later cannot be processed with the following error.

This proposal cannot be executed right now because there are older pending transactions in the Gnosis Safe.

:1234: Code to reproduce
Set up 2/3 gnosis safe multisig wallet.
Send an upgrade request to the proxy contract rather than the proxy admin using the api.
Approve with 2 accounts, and Reject with 1 account.

Hi there,

Thanks for reporting this issue! When rejecting a proposal, there is a short delay before the rejection renders in the user interface. Are you seeing any errors show up in the UI?

Dan McKeon

After rejection, no results are printed in the console log as well as the UI.

Hi @bjjeon ,

We're still working to identify the root cause on this issue, but I want to ensure you get unblocked.

Here's what I would recommend:

You can interact with this gnosis safe directly by going to and typing in your gnosis safe's address, which you can find in the Defender Console. Gather enough votes to reject this transaction and execute the rejection and then send us a response and we will manually update the record so that Defender is in sync with the on-chain state of the gnosis safe.

Please let me know if you run into any issues while doing so.

I tried, but the gnosis safe app does not support the ropsten network where the wallet is deployed.
The wallet is for testing purposes, so it's okay if it doesn't work.

Hi @bjjeon,

Apologies for giving you bad guidance - I did not realize the app only supported a limited selection of networks. I did some further digging on this and it appears the issue you experienced was present on all networks not supported by the gnosis safe app. I pushed a fix for this and it should be in our next release. Hopefully it fixes your issue.

Please reach out if not, we really value your feedback!

Hi @dan_oz, I might have the same issue with a safe on Fantom. When can I expect the next release? Thanks

@bjjeon @antoine

We'll have a release out this coming week

Defender version 1.42.0 has now been released and rejections should work on chains not supported by Gnosis Safe Transaction Service (e.g. ropsten and fantom)

The blocked rejection is completed successfully. Thank you for your efforts to solve the problem

1 Like