Problem with removing liquidity despite changing uniswapv2router address into the new one

Hi guys, i have question. I deployed a token based on a YeetToken SC found below. I made sure that the uniswapv2router address hardcoded was set to the new one as I have seen many issues with this: 0x10ED43C718714eb63d5aA57B78B54704E256024E

I have tested the same SC multiple times on the mainnet and was able to remove liquidity immediately with no issues, thus my confusion with this.

After deployment through Remix, i renounced ownership and added an initial liquidity and received 354 LP tokens in a wallet. After a while, I tried removing the liquidity but to no avail, kept trying and trying but cldnt seem to get it confirmed.

Then i tried withdrawing in amounts of 100LP, after some rapid spamming of my mouse, i was able to get it out, i then repeated it 2 more times.

So heres my question, is it this because Pancakeswap router is lagging due to high volume or is it a part of my contract that is causing this problem!

maxtxamount was set to be total supply of my token, so it didnt seem to be the issue.

swapandliquidy was enabled true, as there was a 5% autolliquidity function in the SC.

the whole idea of having to spam click “confirm” before being lucky and receiving a transanction request on metamask makes me feel like its a pancakeswaprouter issue. what you yall think

appreciate any ideas