Bash: npx: command not found / Unexpected token function

I was following the steps on creating my first zeppelin project. I’m using cloud9 if it matters. Anyway I tried to run this: npx zos init my-project. And I’m getting “npx: command not found”. What do I do now?

1 Like

Honestly, I don’t know about Cloud9. But npx is a binary provided by Node.js, so that’s what you’re missing. However, if Node.js is installed and you still can’t find npx for one reason or another, you can install it as follows: npm i -g npx


Ok so I installed the npx, but now when I run npx zos init my-project, I get “Unexpected token function”.

Hi @SmarterContracter

From a web search, it appears to be a node configuration issue on Cloud9. (I assume you mean AWS Cloud9, unfortunately not something I have used before).

The suggested action appears to be to change the version of node you are using via nvm. You may want to give that a try.


Thanks, it worked. Oh and I was using the original Cloud9 which will close soon since it got acquired by AWS, but I think they are still quite similar, if anyone else is having the same problem.


Hi @SmarterContracter glad that resolved your issue.

Just to let you know that ZeppelinOS 2.3.0 has been released

We would appreciate any feedback on your experience with ZeppelinOS.

Also it would be great if you could take a moment to Introduce yourself here! and let us know what you are working on.

Welcome to the community.