Polygon: Admin Dashboard "Failed to Fetch" when Approving proposals

:computer: Environment

Defender > Admin > Proposal Approval or Proposal Approval & Execution.


An Admin proposal we've created is not capable of being approved. The proposal consist on an ERC-20 transfer, which balance is enough. After clicking "Aprove" it shows "Failed to Fetch". Seems this issue is recent because we have been able to do so in the past week.

Attaching the screenshot of the logs.

Hi @ubinatus ,

This looks similar to other errors we've seen pertaining to flaky providers and/or unsupported wallets. Which wallet are you using and would it be possible to try a different provider?

Hi @dan_oz . Using MM connected to https://polygon-rpc.com as RPC.

I notice the Safe Transaction Service call is being blocked as is the Sentry call. Is it possible there are security settings on your browser that are preventing certain requests?

If you've ruled out this issue, we would need the proposal ID (contained in URL of the proposal) in order to debug further.

Hi @dan_oz

Currently using Brave. Previously this was working like a charm. Even tried disabling the ad/tracker blocker on Brave (turning off the Brave shield) but it's not working. Also tried on Chrome but with same results. Attaching the errors:

And, ofc, both wallet and multisig have the necessary funds (for gas and for sending funds, respectively)

Maybe it's related with the new API change from gnosis (now Safe Global)?

The proposal ID is 2cff063d-ec69-41c0-9a55-855898241a7c.