Help Using AddLiquidity function (uniswapv2router)

Hello all! I deployed a smart contract called myobu ( on the rinkeby testnet to test how uniswapv2router works and deploying a contract. The code obviously works as it is from a deployed contract, however I am unable to call the addLiquidity function due to this error :

"Gas estimation errored with the following message (see below). The transaction execution will likely fail. Do you want to force sending?
execution reverted: TransferHelper: TRANSFER_FROM_FAILED { "originalError": { "code": 3, "data": "0x08c379a0000000000000000000000000000000000000000000000000000000000000002000000000000000000000000000000000000000000000000000000000000000245472616e7366657248656c7065723a205452414e534645525f46524f4d5f4641494c454400000000000000000000000000000000000000000000000000000000", "message": "execution reverted: TransferHelper: TRANSFER_FROM_FAILED" } } "

I tried locating a transferfrom that could have failed but can't find where that function would have been called. Could anyone help me understand why a contract with no changes to it would fail when I try to deploy it? I am able to send the tokens and trade with the owner account on uniswap, but no other address is able to buy or sell it.

One thing I noticed in the remix debugger is that uniswapv2router address is a bunch of 0s, same with factory.

have you called approve() on the token(s) to allow the router to use transferFrom() ?

I called approve on my token contract address and still same error.

Anything else you recommend trying?

It looks like the address declaration is declared within the liquidity function so I guess it might be a problem?