Ethernaut - max fee more than block base fee

I am trying to do Ethernaut CTF but I am getting an error on my very first call that max fee per gas is less than block base fee...I have already read the previous forum post on this and the solution didn't work for me. I have also tried adjusting the max fee and priority fee and gas limit in Metamask, but Metamask won't let me set the gas limit higher than around 79million and that doesn't seem to be high enough.

Also, when I set the max fee and max priority fee high and the gas limit high, it says it will use a huge amount of sepolia ETH, which is a bummer because I want to do all the challenges and sepolia ETH is somewhat limited. Does anyone know what could help? I also tried specifying the gasPrice in my call, but that was rejected as an unexpected parameter. I put a screenshot below so you can see the errors I am getting.

Here is the error...even when I increase the gas limit as high as MetaMask will let me, it is nowhere near enough for these gas figures:

RPC Error: err: max fee per gas less than block base fee: address 0x52e924c387F42D3cb9341ccC6F0914150Aa435B0, maxFeePerGas: 161377630 baseFee: 11643617678 (supplied gas 2000000)

Here is the errors I am getting even after adjusting the advanced fee settings:

Can I ask what you are trying to achieve with your contribution?

The criteria according to the receive fallback function is merely to contribute >0.001 ETH. I think the value you would be looking to insert is 1wei represented merely as a value of 1. No need to change block base fee etc.