Defender admin function does not show functions mint and burnable but only transfer en renounceOwnership


I am trying to develop my smart contract with a mint function and timelock. I followed the following workshop:

I ran into a problem. In the 'New Admin Action' for the token, I only have the following two options: renounceOwnership & transferOwnership.
Why can't I see the other functions like mint and burn? I used Mumbai testnet instead of rinkeby.


kind regards

Hi AM10,

Thanks for reaching out.

Can you please verify that you have copied correct and full ABI of the contract?
If ABI looks good then could you send the contract address (if verified?) to defender support email (so we can check).



hij Zeljko!

thank you for your reply! I tried to run the contract on a mainnet, and the problem is solved. :slight_smile:

The past 2 days I have been playing around a lot with my contract and defender, really cool.
Altough I learned a lot, I have not achieved what I wanted.
The initial idea why I used defender, was to create a timelock. A very simple schedule for unlocking the main balance of my project over the years to give confidence to the token holders. Every year it should release some predetermined tokens.

Unfortunately I still can't find what I have to do. I would expect that I need to use the 'schedule' function out of the timelock contract. Or should I do something from the main contract?

looking forward to your feedback.

kind regards,