Unable to update governance storage by creating proposal

I am trying to increase the Voting period in OZ governor contract, by creating a proposal and then executing it. And I am doing this via Tally, which allows to simulate a proposal before creating, and when I ran the simulation, it failed.

This error is something new to me, before I dig into the code, any help will be appreciated.
Here is the simulation - https://dashboard.tenderly.co/public/tallyxyz/project/simulator/a22d7f0c-6946-4933-af85-81b8debd7fa3?trace=0

Just to be sure, this is the correct way to create a proposal to update anything inside the governor itself, right?

1 Like

Yes, this is the correct way of doing it.

The simulation fails because what you simulate is a call to setVotingPeriod that targets the governor. The simulation is missing the part in execute() that whitelists the operation before executing it.

This is a protection that is usefull when the executor is a third party, that may execute call that do not originate for the governor.


Thank you for replying ser.

So you mean the transaction will be successful, if I go ahead with it, despite the simulation failing.

Should I create the proposal and execute then?

1 Like

Yes. I think you should be good.

If you are not sure and want to performs more tests, your options are

  • to run a full test (proposal + voting + execution) on a live testnet such as sepolia.
  • to run a full test (proposal + voting + execution) in a forked environment (using hardhat or foundry)
1 Like

yeah, I went for the execution, it worked. Thanks a lot.