Unable to deploy the smartcontracts using truffle upgrades. Nothing is working

I am actually trying to deploy my smartcontracts using @openzeppelin/truffle-upgrades plugin.
I am not able to deploy it even once. There are lots of issues I encountered while deploying actually in Testnets. I am using ETC testnet (Kotti).
Here is my truffle config:

 kotti: {
      provider: () => new HDWalletProvider(
        MNEMONIC,
        "https://www.ethercluster.com/kotti"),
      network_id: 6,
      timeoutBlocks: 200000,
      confirmations: 2
    }

One of my migration file(just for sample reference):

const { deployProxy } = require('@openzeppelin/truffle-upgrades');

const contractA = artifacts.require("contractA");
const contractA_v1 = artifacts.require("contractA_v1");

module.exports = async function (deployer) {

  //First deploy non-upgradeable
  deployer.deploy(contractA_v1).then(async () => {
    // then deploy upgredeable
    const ContractAInstance = await deployProxy(contractA, [], { deployer, initializer: 'contractConstructor', unsafeAllowCustomTypes: true });
    ContractAInstance.verifiedUserInit(contractA_v1.address);

  })
};

My issues most of the time is

: PollingBlockTracker - encountered an error while attempting to update latest block:

which is then followed by TIMEOUT & SOCKETTIMEOUT.
It is really frustrating. I even tried using stable internet connection and also used VPN. Nothing worked for me.

I have posted this concern in every possible forums including stackoverflow , truffle github etc. I heavily doubt this is something related with truffle and truffle upgrades plugin because with remix its working absolutely fine and I am able to deploy via remix.

I am expecting serious help from this forum now.

You're missing an await:

await ContractAInstance.verifiedUserInit(contractA_v1.address);

Although I'm not sure this is the cause of the error.

Have you confirmed that you can deploy a non-upgradeable contract?

const instance = await ContractA.new();

await is never an issue.
Yes non-upgradeable won't take much time and it will deploy without any issue. When it comes to the upgradeable one it's taking some time and then issue occurs.

Is there a stack trace for the error that you can share?

I have submitted bunch of issues in github while deploying in multiple networks like polygon mumbai , kotti and so on.

It is especially happening in polygon mumbai and kotti test net which i use the most.

Can you share a repository to reproduce the problem

No I can't. Its kinda confidential. Just try a simple upgradeable contract may be 3-4 contracts. It will fail . Try in polygon mumbai or kotti config