Source "@openzeppelin .... " not found: File import callback not supported

What’s the recommended way to deal with this:

I tried ../../node_modules/@openzeppelin/... but got some really weird behavior then:

Where it somehow throws a DeclarationError: Identifier already declared across two unrelated import statements.

1 Like

Hi @gitpusha,

Assuming you are using VS Code for your IDE and you are using Juan Blanco’s VS Code Solidity extension, then you need to use the following settings:

Link is also in: VSC extension recommendations

1 Like

Hi @gitpusha,

Just checking if this resolved your issue in VS Code?

1 Like

Yes it did indeed … !

1 Like