Relay giving 400 response

Hi, my relay is only giving 400 errors when trying to sign.
DefenderApiResponseError: Request failed with status code 400
at rejectWithDefenderApiError
Relayer ID a1fde32c-ca0e-4ef1-b1d7-85469f476e39
Can you help ?

Calling the getAddress endpoint works perfectly
using import { DefenderRelaySigner, DefenderRelayProvider } from "defender-relay-client/lib/ethers";
"defender-relay-client": "^1.7.0",

Hi please provide a full code snippet and point out where in the code you're getting the error. Thanks!

Ok, the problem is solved and you have two issues :

  • it's undocumented when you use the lib ( you get an error 400 but no explanation)
  • it's a simple rounding error

When the Eth balance of the relay is 0.009 Eth... It's not correctly rounded and it's interpreted as 0.

But on L2 that's enough for a lot of transactions!

So I received an email alert about the low amount ... And I was not able to use the relay because the balance was too low ... But it was not.

So I topped it up with 0.01 and all worked as planned