Problem with truffle and hardhat in macos

ERROR IN TRUFFLE

Error: Truffle is currently using solc 0.5.16, but one or more of your contracts specify "pragma solidity ^0.8.0".

Please update your truffle config or pragma statement(s).
(See https://trufflesuite.com/docs/truffle/reference/configuration#compiler-configuration for information on
configuring Truffle to use a specific solc compiler version.)

ERROR IN HARDHAT

> HardhatError: HH110: Invalid JSON-RPC response received: <h1>Not Found</h1><p>The requested resource was not found on this server.</p>

:computer: Environment

:memo:Details
error compiling contracts 0.8.0 in macos

:1234: Code to reproduce

    /**
     * Use this file to configure your truffle project. It's seeded with some
     * common settings for different networks and features like migrations,
     * compilation and testing. Uncomment the ones you need or modify
     * them to suit your project as necessary.
     *
     * More information about configuration can be found at:
     *
     * trufflesuite.com/docs/advanced/configuration
     *
     * To deploy via Infura you'll need a wallet provider (like @truffle/hdwallet-provider)
     * to sign your transactions before they're sent to a remote public node. Infura accounts
     * are available for free at: infura.io/register.
     *
     * You'll also need a mnemonic - the twelve word phrase the wallet uses to generate
     * public/private key pairs. If you're publishing your code to GitHub make sure you load this
     * phrase from a file you've .gitignored so it doesn't accidentally become public.
     *
     */

    const { projectId, mnemonic,etherscanApiKey } = require('./secrets.json');
    const HDWalletProvider = require('@truffle/hdwallet-provider');

    module.exports = {
      /**
       * Networks define how you connect to your ethereum client and let you set the
       * defaults web3 uses to send transactions. If you don't specify one truffle
       * will spin up a development blockchain for you on port 9545 when you
       * run `develop` or `test`. You can ask a truffle command to use a specific
       * network from the command line, e.g
       *
       * $ truffle test --network <network-name>
       */

      networks: {
        // Useful for testing. The `development` name is special - truffle uses it by default
        // if it's defined here and no other network is specified at the command line.
        // You should run a client (like ganache-cli, geth or parity) in a separate terminal
        // tab if you use this network and you must also set the `host`, `port` and `network_id`
        // options below to some value.
        //
        // development: {
        //  host: "127.0.0.1",     // Localhost (default: none)
        //  port: 8545,            // Standard Ethereum port (default: none)
        //  network_id: "*",       // Any network (default: none)
        // },
        // Another network with more advanced options...
        // advanced: {
        // port: 8777,             // Custom port
        // network_id: 1342,       // Custom network
        // gas: 8500000,           // Gas sent with each transaction (default: ~6700000)
        // gasPrice: 20000000000,  // 20 gwei (in wei) (default: 100 gwei)
        // from: <address>,        // Account to send txs from (default: accounts[0])
        // websocket: true        // Enable EventEmitter interface for web3 (default: false)
        // },
        // Useful for deploying to a public network.
        // NB: It's important to wrap the provider as a function.
        rinkeby: {
        provider: () => new HDWalletProvider(mnemonic, (MNEMONIC, API_URL)),
        network_id: 3,       // Ropsten's id
        gas: 5500000,        // Ropsten has a lower block limit than mainnet
        confirmations: 2,    // # of confs to wait between deployments. (default: 0)
        timeoutBlocks: 200,  // # of blocks before a deployment times out  (minimum/default: 50)
        skipDryRun: true     // Skip dry run before migrations? (default: false for public nets )
        },
        //Useful for private networks
        // private: {
        // provider: () => new HDWalletProvider(mnemonic, `https://network.io`),
        // network_id: 2111,   // This network is yours, in the cloud.
        // production: true    // Treats this network as if it was a public net. (default: false)
        // }
      ///},

      // Set default mocha options here, use special reporters etc.
      mocha: {
        // timeout: 100000
      },

     // Configure your compilers
      compilers: {
        solc: {
          version: "0.8.0",    // Fetch exact version from solc-bin (default: truffle's version)
          paser : "solcjs",      // Use "0.5.1" you've installed locally with docker (default: false)
           settings: {          // See the solidity docs for advice about optimization and evmVersion
           optimizer: {
              enabled: true,
           runs: 200
        },
        },
      },
    },
    // 
      }
    }

CODE IN HARHDAT

c    onst { alchemyApiKey, mnemonic } = require('./secrets.json');

    require('@nomiclabs/hardhat-truffle5');
    require('@nomiclabs/hardhat-solhint');
    require('solidity-coverage');
    require('hardhat-gas-reporter');
    require('@openzeppelin/hardhat-upgrades');
    require("@nomiclabs/hardhat-ethers");
    require("@nomiclabs/hardhat-waffle");



    const enableGasReport = !!process.env.ENABLE_GAS_REPORT;
    const enableProduction = process.env.COMPILE_MODE === 'production';

    /**
     * @type import('hardhat/config').HardhatUserConfig
     */


    module.exports = {
      defaultNetwork: "rinkeby",
      networks :{
        hardhat :{
          blockGasLimit: 10000000
        },
        rinkeby:{
          url:"https://eth-rinkeby.alchemyapi.io/v2/${alchemyApiKey}",
            accounts: {mnemonic: mnemonic}
        }
      },
      solidity: {
        version: '0.8.0',
        settings: {
          optimizer: {
            enabled:true,
            enabled: enableGasReport || enableProduction,
            runs: 200,
          },
        },
      gasReporter: {
        enable: enableGasReport,
        currency: 'USD',
        outputFile: process.env.CI ? 'gas-report.txt' : undefined,
        }
      }
    };
1 Like

Hi @Guard_Colombia,

As these issues are unrelated, it is better to create two separate topics.

Your truffle-config.js appears to specify the compiler version as 0.8.0.

You have a typo, paser should be parser, not sure if this is causing the issue.
See Truffle docs: https://www.trufflesuite.com/docs/truffle/reference/configuration#solc

I would try replacing this section with:

compilers: {
    solc: {
      version: "0.8.3",      // Fetch exact version from solc-bin (default: truffle's version)
      // docker: true,        // Use "0.5.1" you've installed locally with docker (default: false)
      // settings: {          // See the solidity docs for advice about optimization and evmVersion
      //  optimizer: {
      //    enabled: false,
      //    runs: 200
      //  },
      //  evmVersion: "byzantium"
      // }
    },
  },

From: https://docs.openzeppelin.com/learn/developing-smart-contracts?pref=truffle#compiling-solidity-source-code

I would check your network configuration. Ensuring that your Alchemy API key is correct (you can try printing it out) and that it is a valid URL for Alchemy.

See: https://docs.openzeppelin.com/learn/connecting-to-public-test-networks?pref=hardhat#configuring-the-network