I can't add liquidity, seems to be something wrong with my token

Hi, I have deployed a smart token to BSC but have done something wrong I think. I cannot add liquidity to it via pancake swap and really just can't seem to do anything with it (json rpc error)

** The same code works on BSC testnet, doesn't seem to be a problem there**

The one thing I think I may have stuffed up on is I sent 80% of my tokens to the contract address before I tried to add liquidity. I am assuming this might be my issue??

If not, any ideas what I am doing wrong - your help would be most appreciated.

This is my first token, and is just a joke token really so I could practise and learn, however I still wanted it to function a little.

** I have just tried to send the remaining 20% of tokens to the contract address as a desperate attempt to try and get something to happen but transactions failed.


Okay, so I have been testing with BSCTestnet, trying to replicate what I have done with the same code.

Clearly I have messed up by sending tokens to the contract before adding liquidity. When I do this in testnet I get the same results. But when I add liquidity first then everything is working fine.

So I guess my only question now is what can I do?

All I think of is deploying the contract again with a different address and just ignoring this one?

Is there a better way to try and reverse this?

Thanks, any suggestion would be really appreciated.