"Error while storing shell tx, decrementing nonce"

I am getting this error when trying to submit a transaction through the relay. I sent the exact same transaction earlier in the day so I know I am authenticating and sending transactions correctly.

:computer: Environment

chain: Polygon


This is the transaction that was successful. I am now getting the error when trying to submit the same thing. I can't find any mention of this error on the internet and the error message isn't helpful at all. Is the transaction too large? I don't see any problems with overflowing data types

My relayer ID is 9d37614f-a3f7-49e6-b201-2272ee061382

:1234: Code to reproduce

1 Like

I am getting the same error as well on a deployment script that previously worked:

DefenderApiResponseError: Request failed with status code 500
    at rejectWithDefenderApiError (/Users/simonmullaney/Desktop/Ethereum/Metablaze/mblzTokenBackup/mblz/node_modules/@openzeppelin/defender-base-client/lib/api/api.js:10:27)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async /Users/simonmullaney/Desktop/Ethereum/Metablaze/mblzTokenBackup/mblz/node_modules/@openzeppelin/defender-relay-client/lib/api/index.js:93:21
    at async ApiRelayer.apiCall (/Users/simonmullaney/Desktop/Ethereum/Metablaze/mblzTokenBackup/mblz/node_modules/@openzeppelin/defender-base-client/lib/api/client.js:43:20)
    at async DefenderRelaySigner.sendTransaction (/Users/simonmullaney/Desktop/Ethereum/Metablaze/mblzTokenBackup/mblz/node_modules/@openzeppelin/defender-relay-client/lib/ethers/signer.js:124:15) {
  request: { path: '/txs', method: 'POST' },
  response: {
    status: 500,
    statusText: 'Internal Server Error',
    data: { message: 'Error while storing shell tx, decrementing nonce' }

Hi @gripnr and @Simon_Mullaney,

Thanks for reaching out to us and sorry for the late response.

In order to assist here some additional information would help me in doing so - first of all is the issue still occurring for both of you? Are you sending the transaction through the UI or the via the API client?

@Simon_Mullaney could you share your relayerId and the time roughly the error occured

Yes, I just got the same error again on a different relay (f640e21d-2559-4f5c-850d-5bee052967c1) under the same account.

@gripnr Thanks for sharing your relayer, after examining several transactions where this error appeared, I have determined that the issue is due to the transaction size being too large for our database to handle. We will continue investigating whether we have any solutions to resolve this, but given the nature of this limitation, I'm unable to provide a definitive timeline or guarantee that we will find a resolution.