Avalanche autotasks failing with error unhandled

All autotasks in avalanche are failing with error "Error while attempting request: Unhandled". they worked till yesterday, but it is failing now. please check asap

@spalladino @MartinVerzilli can you please check asap

We have the same issue. Worked fine for weeks. Started failing during the night (UTC).
Some executions throw this error which is the only error message that makes any sense so far:

[ERROR] [1647248344877] LAMBDA_RUNTIME Failed to post handler success response. Http response code: 403.

To be clear, we are not calling any of our own servers. This HTTP 403 is an error from Openzeppelin.

Hi @kbhargav5 @undergroundadmin

Could you please send an email to defender-support with some details, e.g. the autotask ID. Is it only Avalanche you're seeing issues with?

Actually, Autotasks also fail when not making any blockchain requests (web3).
I will send the autotask IDs that both fail to support.
It would be amazing if you can help us fix it, as they were working fine yesterday and during the night they stopped working without any code changes from our side.
They stopped working around 4am UTC 14th March 2022.

Thanks @undergroundadmin, we have found the root cause of the issue. Seems like this has been stabilised for now, and we are working on a fix to reduce the chances of this happening again.

Thank you for your patience.

1 Like

Very much appreciated. Thanks a lot.