Upgradeable contracts can not be edited on opensea platform

Hey. I used the ERC721PresetMinterPauserAutoIdUpgradeable preset to deploy my erc721 contract. Then I mint some NFT using the deployed contract. Also I tried to upgrade the contract and it was successful, but there is one problem. When an erc721 contract is deployed on the blockchain and its first NFT was minted, then we can see this contract as a collection on the Opensea marketplace. The owner of the contract can edit the config of the collection on the Opensea, like its logo, description and royalty. When I use these upgradeable contracts, the platform does not allow me to edit the collection. Here is the problem. Any help or suggest would be appreciated <3.

Btw, I used non-upgradeable contracts and they were OK. I can edit their corresponding collections on the Opensea.

:computer: Environment

I used truffle, and also tried hardhat to deploy.
solidity compiler version 0.8.2
openzeppelin contracts version ^4.2.0

In case someone encountered with the same problem:
Opensea tries to call the function owner() from the contract, so if you use AccessControl module, you should also define the owner() function in your contract that returns the owner address.

Good luck <3.