Unable to Verify Contract Using Hardhat/PolygonScan

Unable to Verify Contracts On PolygonScan

There has been an issue when I am trying to verify two smart contracts using hardhat and polygonscan itself. I will summarize both my attempts below and at the end I will ask for help.

Unable to Verify Contract Through Hardhat


I ran: npx hardhat verify --network polygon 0x39652163c7C1BEe9E00dF3c4ce0292F52bEb1815 --constructor-args argsBC.js

All arguments are the same ones used when deploying the contracts.

Unable to Verify Contract Manually

I went on Polygoscan and tried verifying it by hand. It gives me an error due to the openzeppelin imports. I then flattened it and tried again.


I compared the bytecode expected with the bytecode of the BaseContract in a text comparing tool online and they're exactly the same. I don't know why polygoscan up there says they have compared the expected with all below and they all mismatch.


I would like to receive help on identifying what is the problem that is avoinding this contract to be verified.