Transaction was not mined within750 seconds, please make sure your transaction was properly sent

My token deployment on Main network timedout after 750 seconds with zos create, while the whole process was confirmed on public blockchain after 830 seconds.
Can we increase this timeout-value somehow, maybe as an argument on CLI?


Since we use the Proxy contracts, I’m not sure which contract address I can use as the token-address for my CrowdSale-Crontract.

Is this the “to”-address on that is labeled with “contract”?

1 Like

You can specify the timeout.
--timeout <timeout> timeout in seconds for each blockchain transaction (defaults to 600s)


Hi @itinance

When interacting with the contract, use the Proxy contract address.

You can always open a truffle console to test this.

Although I used zos create --network main --timeout 123123123123, it timedout with

Transaction was not mined within750 seconds, please make sure your transaction was properly sent. Be aware that it might still be mined!

Is there any chance to make it work longer than 750 seconds? ^^

1 Like

You have logged the timeout as

1 Like

@abcoathup obviously this parameter is not used, as the timeout still is happening. Although I can find out the contract address later on, I can’t interact with zos-cli as long as no valid contract addresses are known to the tool.

I would patch my zos.mainnet.json by myself now according to the values in zos.ropsten.json, but with address values from

The second attempt for the token contract went through, but still not for token sale contract.

"ncdt/NCDToken": [
    "address": "0x5ac288CC5Ae7a81A01fdD5985bc6B28d4e1A736A",
    "version": "v1.3.0",
    "implementation": "0x0456Cf3Df2e4922808d6a00b0c20bA0D75E938ea",
    "admin": "0x731FE02eCa76de08EA9F1A9A68A5d863124c4D41",
    "kind": "Upgradeable"

So I will adapt the same structure in the json-file for TokenSale-contract as well with values found on… Would be really cool if CLI-tool could wait until the process on-chain is completed without any timeout :slight_smile:

1 Like

I assume that something else is causing the timeout, e.g. 50 blocks would be approximately 750 seconds.

The gas market has been fluctuating, which doesn’t help matters.

My settings for gas consumtions are:

  gas: 8000000,
  gasPrice: 10000000000

Do you think, I should raise in order to avoid the timeout?

1 Like

It depends what the gas market is like when submitting your transaction.
I recommend looking at

medium gasprice: 10 gwei

Although I doubled to 20 gwei, I’m constantly running into this 750 seconds timeout.

1 Like

I just hit the 750 seconds timeout too when attempting to deploy a sample contract.

Thanks for testing it, @abcoathup!

Could you add your experience also on the github issue please:

Will give it more attention hopefully.

1 Like

I have executed a “addMinter”-Method in the Token contract, it was running into 750-second-timeout too, is still get mined for over 14 minutes now:

1 Like

As of a sudden everything worked really fast. Contract deployment, creation and executing methods was done within seconds. I don’t know what happened before, but according to there was seemingly an airdrop happening, that flooded the transaction log. Maybe some traffic jam on the chain back then ^^

1 Like

Hi @itinance
It appeared to be congestion yesterday that was causing the deployment issues we both experienced. I check

There is still an underlying issue of the 750 second timeout, though glad for now it is not impacting you. (I deployed my sample contract this morning with no issues)

Same here :slight_smile: The underlying issue with fix 750 seconds timeout is still there as you wrote. That’s why I don’t closed my issue on GitHub regarding this. But I think it needs to my escalated to Web3

1 Like

I am not clear if the issue is with zos, truffle or web3. It will need some investigation to track down. So agree, it is worth keeping the issue open.

1 Like