Strange error on Mumbai's polygonscan


I have a write function to add an array of addresses, I put for example this:


And the polygon scan (not metamask), says this error:

invalid address (arg="addresses", coderType="address", value="0xddC5f73aB04FbcE9fF79AA07D0A4196BD0285f46"")

Check how it adds at and a " at the end. Any ideas what is happening? All the other write functions work.

Maybe you can delete " to have a try, that is just pass [0xddC5f73aB04FbcE9fF79AA07D0A4196BD0285f46]

Tried it, says the following:

Invalid parameters: must provide an Ethereum address.

check your metamask network

Yes, I'm indeed on polygon testnet, called Mumbai.

Any ideas to what can I do? Is interacting with the contract from Remix my only recourse?

Yeah that's strange. I would try removing the square brackets. And different combinations of square brackets and quotes...

Hi sir

i having the same problem. test on rinkeby it works , however the same error prompt when switch to mumbai network. May i know what the root cause?

Hi Sir

do you able to idnetify what the error ? i having same issue as well .

its working fine in other netowork such as rinkeby