OZ send-tx/call fails to execute intermittently

Whenever I reopen my OZ projects after a while, say a couple of days, when I run oz send-tx or oz call, I get an error message like this Could not load truffle configuration file. Error: Cannot find module 'eth-block-tracker'.

Most times, it responds with some other missing module. This has happened more than once. The last time it did, I had to delete my node modules and reinstall my dependencies. Can your team kindly look into this?

:computer: Environment

oz version 2.5.3


The incident as described above happens on a mac.

:1234: Code to reproduce

No code

1 Like

Hi @mayorcoded,

I’m sorry that you had this issue. We would need more information so that we can reproduce it.

Can you provide the version of the CLI you are using, as well as the operating system, node and npm versions? Any other details that might help us reproduce it would be appreciated!

oz version: 2.5.3
macOS Mojave: 10.14.4 (18E226)
node: v10.15.1
npm: 6.4.1

Other info: it occurs when I try to reuse my oz-cli after a while. Say 2-3days.

1 Like

Hi @mayorcoded,

You may want to upgrade to a later version of OpenZeppelin CLI.

The latest version is: OpenZeppelin CLI 2.7
There is also a release candidate of: OpenZeppelin CLI 2.8

I will see if I can reproduce the error loading the truffle configuration:

1 Like

Hi @mayorcoded,

I haven’t been able to reproduce so far. I suggest updating to the latest version of the OpenZeppelin CLI.

FYI: OpenZeppelin CLI 2.8 release candidate supports regular (non-upgradeable) deploys too.

Hi @mayorcoded,

Unfortunately, I haven’t been able to reproduce.

Have you tried upgrading to the latest version of OpenZeppelin CLI?

A post was split to a new topic: How do I fix Proxy at address not found?