Npx hardhat verify stalls out on "waiting for verification result"

npx hardhat verify --network rinkeby 0xfa0efcD39f4480273a80F734F3597C99B62908e8

Outputs:

Nothing to compile
Compiling 1 file with 0.8.4
Successfully submitted source code for contract
contracts/PokerHandsTest.sol:PokerHandsTest at 0xfa0efcD39f4480273a80F734F3597C99B62908e8
for verification on Etherscan. Waiting for verification result...

Now it doesn't do anything and just waits forever for the verification result. No error message, nothing. Very frustrating.

3 Likes

Ah!!! Ok, so it is not just me! Yep, this has been happening to me since yesterday night!

The weird thing too is that my Etherscan API Key shows I've had no activity in the last week even though I've verified many contracts since...

Experiencing the same thing over here. Anyone figure out what was going on, or try again later and it worked? Thanks.

1 Like

Yeah, having the same issue. Did anyone get to a solution?

1 Like

Yes, I'm having this problem right now too. It just waits for validation without returning any error messages.

1 Like

yes same seems to be an issue that just popped up?

1 Like

ya same problem here, so this problem come from bscscan / etherscan etc ?

I am having the same issue on Polygonscan too.
I am using the latest 3.0.0 hardhat etherscan plugin.

Same problem here. On Bsc and bsc-testnet

same thing on Avalanche both Testnet and Mainnet

I follow this problem very closely. It is a pity that it is still not resolved.

same problem for me....

Update: mine did eventually go through on mainnet. requested scan last night , came in today and they were verified so not sure exactly how long it took, but it was several hours at least.

Update: it did eventually went through.
it did however took over couple hrs.

For me its alive :slight_smile: A few minutes ago verified contract on BSC testnet without any delay