Not able to install @openzeppelin/network

Hi Team,

I am Vandana. I was going through the tutorial for Gas Station Network. I have Ganache and Git installed on my Windows 10. When trying to run “npm install @openzeppelin/network”, I am getting the below error. Can you please help me in resolving the issue?

C:\Users\MY\Desktop\ethereum\gsn-dapp>npm install @openzeppelin/network
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated mkdirp@0.5.4: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)

@openzeppelin/network@0.4.2 preinstall C:\Users\MY\Desktop\ethereum\gsn-dapp\node_modules@openzeppelin\network
ln -s ./lib/react ./react

‘ln’ is not recognized as an internal or external command,
operable program or batch file.

scrypt@6.0.3 preinstall C:\Users\MY\Desktop\ethereum\gsn-dapp\node_modules\scrypt
node node-scrypt-preinstall.js

npm WARN gsn-dapp@1.0.0 No description
npm WARN gsn-dapp@1.0.0 No repository field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @openzeppelin/network@0.4.2 preinstall: ln -s ./lib/react ./react
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @openzeppelin/network@0.4.2 preinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\MY\AppData\Roaming\npm-cache_logs\2020-03-24T14_01_57_058Z-debug.log

1 Like

Hi @VandanaKamal,

As you have Git installed, you can install OpenZeppelin Network.js using Git Bash terminal.

Though I would recommend moving to using Windows Subsystem for Linux (this is what I use).
See Solidity Smart Contract development on Windows for details.

1 Like

Thanks @abcoathup. I tried installing on ubuntu machine and it worked for me.

1 Like

Great to hear. So much of the ecosystem is *nix based so it is much easier to develop on a *nix based system. I am currently using WSL 2 on Windows.