Metadata works & shows up in Testnet but hasn't showed up on mainnet

Hello Everyone, I have a launched a ERC-721 Contract on remix using rinkeby, I did not add the baseURI into the Hardcode, instead I added it using the SetBaseURI command, and it worked perfectly my Metadata and Images loaded up within minutes on testnet.opensea here is the link:

Now my issue is, I used the same exact process for my contract on the Mainnet but, for some reason the Metadata or images haven't appeared on Opensea.

Here is the Collection Link:

It's been hours since I updated the BaseURI and still nothing has showed up, any idea why? I heard that maybe it won't switch until a transaction occurs like a mint or trade, is that true?

Any help would be greatly appreciated.

OpenSea has an refresh metadata button. Have you tried using that?

1 Like

haha really? Yes, of course I tried that, I've tried minting new tokens, I just tried the baseURI command again, to see maybe it'll go through now.

I was speaking to Opensea Support lastnight and they said they were undergoing maitenance and were attending to it trying to get fixed.

Not really sure what the issue is, epscially since it works perfectly fine on testnet.opensea per remix.

i checked and your image metadata is wrong.

"image": "ipfs://QmVctaXJSYv8cdv56Fv6ShkLQmCNZLTBgwxzBsPYYoSs5w//1.gif",

has 2 // before #.gif

That is probably causing the issue