HardhatError

For more info go to https://hardhat.org/HH600 or run Hardhat with --show-stack-traces
PS C:\Users\user\Desktop\Testing 2\hello-world> npx hardhat run scripts/deploy.js --network ropsten
HardhatError: HH700: Artifact for contract “HelloWorld” not found.
at Artifacts._getArtifactPathFromFiles (C:\Users\user\Desktop\Testing 2\hello-world\node_modules\hardhat\src\internal\artifacts.ts:391:13)
at Artifacts._getArtifactPath (C:\Users\user\Desktop\Testing 2\hello-world\node_modules\hardhat\src\internal\artifacts.ts:316:17)
at Artifacts.readArtifact (C:\Users\user\Desktop\Testing 2\hello-world\node_modules\hardhat\src\internal\artifacts.ts:49:26)
at getContractFactoryByName (C:\Users\user\Desktop\Testing 2\hello-world\node_modules@nomiclabs\hardhat-ethers\src\internal\helpers.ts:100:20)
at main (C:\Users\user\Desktop\Testing 2\hello-world\scripts\deploy.js:2:24)
PS C:\Users\user\Desktop\Testing 2\hello-world>

Anyone can help me in it?

Welcome to Open Zeppelin 3d.

In your deploy.js make sure you have the right token name.

For example

const Token = await ethers.getContractFactory("CONTRACTTOKENNAME");

It’s what you defined your contract’s name as in the .sol file.

If this still doesn’t work do npx hardhat clean - this sometimes fixes errors that have no rhyme or reason.