ERC20 Total Supply is 0 after deployment

I’ve created ERC20 Upgradeable token using the OpenZeppelin library.
Deployed it in rinkeby.
Followed instruction on how to create a token with max supply:
https://docs.openzeppelin.com/contracts/2.x/erc20-supply

And this is the result:

I don’t think Rinkeby shows Max Total Supply of tokens.
I’ve never seen a contract on Rinkeby that shows Max Total Supply.

Check where you minted the tokens.
If you sent them to yourself, then you should have them.
If you sent them to the contract you should be able to see the supply in the token drop down.
You can see them on the contract token page, and your own address’s page in Rinkeby.
From your code it looks like you minted them to the deployer/owner/initializer, so if that’s you, check your address for the tokens.

FYI you also can’t see the token holders on Rinkeby.

1 Like

Would it be the same in ropsten?

Regarding the owner, I’m the owner indeed in Ropsten and Rinkeby

Total Supply is really 0 in both

How did you deploy it? Have you called the initializer?

1 Like

Yes, I’ve never seen total supplies or holders be shown in Ropsten or Rinkeby.

1 Like

Could you share an etherscan link to your deployed contract?

2 Likes

(‘AdminUpgradeabilityProxy’)

Token itself

So this piece has deployed 3 contracts:

image

My ropsten address

@martriay
Is it really required to deploy 3 contracts?

1 Like

Hi @dmdv,

I flagged your proxy as a proxy on Etherscan.

You can then interact and read the total supply on Etherscan:

1 Like

Where is it in etherscan?

1 Like

Look at the top right of the code textbox. Click more option and select Verify Proxy. Then click verify with the given address. it should raise an error but it will give you the implementation address. This is the one you use to verify your contract. You could also write a test to find out your total supply.

1 Like