Difficulties verifying smart contract with imports

Hi I am having some difficulties verifying my smart contract I deployed it yesterday and have been trying to verify using Solidity multi part files as the contract contains 2x imports. I keep on getting thrown a parser error : file import call back not supported. I read through another solution on this page but it has not cleared my problem as I get the same parser error with importing from npm and Github

:1234: Code to reproduce

:computer: Environment

Hi, welcome! :wave:

Maybe you can have a look at this tutorial: How to verify a contract on Etherscan/BscScan/PolygonScan

And for the next time, please search at the forum at first, and then ask questions, thanks!
How do I ask a good question? - General / Meta - OpenZeppelin Community

Hey so I have since tried using hardhat to verify but one of my constructor arguments has a space inbetween and the script recognizes it as 2 constructor arguments instead of 1. Removing the space allows me to run verification but it obviously comes back unsuccessfully. With Etherscan I tried running the fullflat Contract but when I enter the Bytecode for that it tells me the Bytecode is missing something for :Address.sol, and 3 others. Although I created the bytecode specifically for this full flat contract. I am really at a loss. I have read through several threads on here

In the shell, you can wrap your argument with quotes so that it's seen as a single argument like hardhat verify ... "my argument" ....

Otherwise, check out the section about complex arguments in the documentation for the Etherscan plugin for Hardhat.

1 Like