Config to persist not enabling typechain support

@pcowgill asked on Telegram:

Every time I run oz compile I’m prompted to reselect whether to enable typechain support, etc.
Is there somewhere I can persist this in a config?

Using OpenZeppelin CLI 2.7.1

In project.json compiler section typechain can be set to enabled false.

project.json

{
  "manifestVersion": "2.2",
  "contracts": {},
  "dependencies": {},
  "name": "mrt",
  "version": "1.0.0",
  "compiler": {
    "compilerSettings": {
      "optimizer": {
        "enabled": false,
        "runs": "200"
      }
    },
    "manager": "openzeppelin",
    "solcVersion": "0.5.16",
    "artifactsDir": "build/contracts",
    "contractsDir": "contracts",
    "typechain": {
      "enabled": false
    }
  },
  "telemetryOptIn": false
}

Hi @pcowgill,

It would be great to reproduce this. Can you can provide any more information? (When you have recovered from the hackathon)