Can't add liquidity on PancakeSwap with burnable ERC20 token

Hi Billy,

The issue might be because 1000000000000000000000000 is your max tx amount.

That might be over the amount you are trying to pull.

Maybe increase that and make sure your numbers are correct?

It’s same as amount that i added liquidity :

i added 1 for “amountETHMin (uint256)” also 1 for remove liquidity , this is may be problem? how can i make 0.5 for uint256 ?

Hi Billy, looking at the contract your total supply is

but your maxTxAmount is

Can you set it to 100% just to make sure.

I removed 9 decimals , but problem still exists , It’s not because of deadline time ?

For deadline just use 1685889467

That is one year from now. I am telling you to set the MaxTxPercent to 100. Please do that so we can remove the issue from the equation.

i did set it to 100 but issue still exists!

Turn off swapAndLiquifyEnabled, set it to false.

The deadline looks good.

I would use less zeros and play with those numbers.

Can you still send tokens?

I turned it off and used less zeros but still can’t remove tokens !

Thanks the steps, able to create the LP on testnet 0xD99D1c33F9fC3444f8101754aBC46c52416550D1 but still not able to test actual trade on pancakeswap. inspite of connecting to testnet, pancakeswap still uses the production address which is 0x05fF2B0DB69458A0750badebc4f9e13aDd608C7F. unfortunately it is not mapped to router contract on testnet, so anything you do on pancakeswap on testnet will end up in a dead address

Try using this for a testnet,

@Billy_Kid the router is 0x9Ac64Cc6e4415144C455BD8E4837Fea55603e5c3


Hello . I can’t thank you enough for this helpful instructions. I tried but i am having an error with the ethmin value

Is there any formula for converting this decimals to uint256?

@Yoshiko thank you for the great explanation - all worked as explained on Testnet


  • Where can I now go and query the LP balance of the admin address? I'd like to check if the LP balance is increasing after each transaction.

Here's my LP creation after following your directions:

were you able to figure this out?

Trying to get some help adding liquidity to my contract. Which yours seems to be nearly identical to mine.

I’ve approved the following transaction:

And finally I get the following error on my transaction, I cannot seem to get this figured out.

I got the same error following those steps as others have mentioned. Read through the comments. Haven’t seen a fix yet. I’ll tinker with it some more. Also did change the SwapAndLiquify to false.

Edit: I got it to work. The issue was that the SwapAndLiquify EVM within BSCScan wasn’t actually calling my contract. I called it from remix to set to false and it worked.

Hi everyBody,
Impossible to remove liquidity

Can you help me ?

Hello @Yoshiko Thank you for posting this. I have a question regarding your guide. I added liquidity in Pancake Swap manually, but I also want the auto liquidity to work. Can these steps be done if liquidity has already been added?

@yoshiko, hello sir, i followed your easy to understand instruction, I done step 1, i tried step 2 and didnt approve bnb/gas fee as im not sure what happens next. so once i complete step 2, is liquidity adding done ? can I start trading straight awy ? what is the significance of using time stamp for a day please. finally do i need to go pancake swap to finish off adding liquidity after doing step 1 & 2. first i tried adding liquidity on pancake swap but nothing happens, i keep clicking creat pool & supply but no result. Please sir kindly reply to me. thank you

0x7605a6e9ca83a16195f30f5aa56c7bf1ffbc d332

i cant add liquidity.. keeps given me this error