Unable to verify contract on bsc mainnet, but works on testnet

Hi,

I have deployed and verified contracts before, but have never experienced this issue before.
The code I have, it worked on BSCmainet before but today I got an error:
" Error! Unable to verify source code
Exception err_code_1 Occured: ERROR - Unable to connect to the remote server"

Also, the code I’m using is working fine on testnet (I was able to verify it), but on the mainnet I get the error above.
Can you explain why this happens?

Thanks.

Welcome to the forums zlatkec!

How are you verifying your contracts?

If you are using API keys, make sure your API key is set to the right network. The API key provider, such as alchemy or infura, might have modified your API key too so check there as well.

Hi, welcome! :wave:

Sorry, I am not familiar with the BSC-Chain, maybe you should ask for help in their forum: Home | Binance Chain Forum

It seems like the RPC of your BSC node is not valid, maybe you can change it to another one to have a try!

I solved it by using a proxy. For some reason it didn’t want to connect to a remote server from my IP any longer. Strange, but ok.

2 Likes