Tried and can't get smart contract to verify on Snowtrace

I've deployed a smart contract to the Avalanche blockchain using REMIX. It worked perfectly. I used the tool directly from Open Zeppelin to create it. The issue I'm having is trying to verify the contract on Snowtrace. I've tried everything I can, and it hasn't worked. I've used the flattener as well with no luck. Any help would be appreciated.

Here is the contract code:

// SPDX-License-Identifier: MIT

pragma solidity ^0.8.4;

import "@openzeppelin/contracts/token/ERC20/ERC20.sol";

import "@openzeppelin/contracts/token/ERC20/extensions/ERC20Burnable.sol";

contract ZLYX is ERC20, ERC20Burnable {

constructor() ERC20("ZLYX", "ZLYX") {

    _mint(msg.sender, 1000000000 * 10 ** decimals());



Hello CryptoKingPin,

I was able to successfully verify your contract on the Snowtrace testnet.

I used a plugin called Truffle Verify. You can find it in the NPM plugin repository.

Your contract works fine. I was able to successfully reproduce it, compile it, and deploy it on Snowtrace. The contract address is 0x4117d6eAd592348046a04ea2dFe6CcE19284fF96

After I was able to deploy the contract, I simply ran the truffle verify command and the contract successfully verified. See image:

Let me know if you have any other questions or need assistance using Truffle Verify plugin.

Good luck.


1 Like

Awesome, thanks for the help!