Deploying on Fantom

Hello, I don't know if that is the right place to ask but I try :slight_smile:
I try to deploy a proxy contract with truffle on FTM mainnet.On ETH it already work. I only changed the networks.

But it looks like the transactions never get submitted.

Output:

Deploying 'Contract'
   -------------------------
   ⠋ Blocks: 0            Seconds: 0   > transaction hash:    0x48d33e61115b79af4b500ac05a22a1131553dfb686f3278162cd5b3a8adceb91
   ⠦ Blocks: 0            Seconds: 0undefined
   ⠙ Blocks: 5            Seconds: 5undefined
   ⠦ Blocks: 10           Seconds: 9undefined
   ⠏ Blocks: 15           Seconds: 13undefined
   ⠸ Blocks: 19           Seconds: 17undefined
   ⠧ Blocks: 23           Seconds: 21undefined
 ... and so on

Truffle-Config:

    ftm: {
      provider: () => 
      new HDWalletProvider({
        mnemonic: {
          phrase: FTMphrase
        },
        providerOrUrl: "https://rpcapi.fantom.network",
        numberOfAddresses: 1,
        shareNonce: true,
        // derivationPath: "m/44'/1'/0'/0/"
      }),
      network_id: 250
      // confirmations: 5,
      // timeoutBlocks: 2000,
      // networkCheckTimeout: 999999,
      // gas: 8500000,           
      // gasPrice: 435000000000,  
      // skipDryRun: true
    },

I tried around with the comments and different RPC like: https://rpc.ftm.tools/
All with the same result. The transaction is never pending if I check the hash on tenderly of ftmscan. If I try out the truffle console everything is just working as expected...

Check for truffle configuration for fantom network

You can try deploying through remix to check if the error is coming from your truffle configuration