Deploy upgradeable contract: "AdminUpgradeabilityProxy" hit a require or revert statement somewhere in its constructor

   Deploying 'AdminUpgradeabilityProxy'
   ------------------------------------
   > transaction hash:    0x5e4ea44e4f5dc09ed63b79adb26f39b44d6a4671452b3bdd050a0db5eb8f5454

Error:  *** Deployment Failed ***

"AdminUpgradeabilityProxy" hit a require or revert statement somewhere in its constructor. Try:
   * Verifying that your constructor params satisfy all require conditions.
   * Adding reason strings to your require statements.
1 Like

Hi @pageone,

Can you share your migrations script (which contains deployProxy), and what network you were deploying to, and what version of Truffle/node/npm you are using? (You can use npx truffle version).

2 posts were split to a new topic: “AdminUpgradeabilityProxy” hit a require or revert statement somewhere in its constructor