Code Inspector failed on some repo

Trying to run Code Inspector for my github repos. For some repo, it reports failed with no details.

Anywhere I can find the reason why it failed? Any particular project structure for Code Inspector to run? It happened for all my repo created from template, other hardhat style repo all succeeded.

Hi @Joyious thanks for reaching out! Could you please share your tenant Id?

I also am getting everything FAILED or RUNNING > 1 hour. My tenant ID is 8494356c-2a5b-4dab-a774-8dd85578dfce

@marcos.carlomagno is that something you can look into on my tenant ID above? Thanks!

Hi! @coffee-converter it looks like a bug, we are working on fixing the issue and we will let you know how to proceed to solve this as soon as we fix it

Apologies for the inconvenience

@coffee-converter it looks like the analysis timed out after +1h.

The repo you are analysing is private, could you provide us the number of solidity files in it? Just to
understand if this is timing out due to the size of the repo.

If that is the case, and you are using foundry or some Solidity-based testing tool, I suggest to create the PR changing the extension of the testing files or deleting them, right now the analysis runs over all .sol files, which can be skipped for tests.

We are working on including some configs to define which files to include in the analysis, but we haven't releases that yet

Ok I'll try making a repo with just the main solidity files, would that work? Like, no libs or tests or anything else...

I tried slimming the test repo down to just my 28 main solidity files. First PR I made hasn't been recognized by the Code Inspector tool. Is there a reason some PRs don't get analyzed?

Ok, latest one worked!

1 Like


If it still helpful. I'll try to rename those foundry test files.


Now it all succeeded! Good work!

1 Like