Cannot verify ERC1967 Proxy in thePolygon Amoy network

Verifying via hardhat is not working

Verifying implementation: 0xxxx
Successfully submitted source code for contract
modules/fund/contracts/v1.11/Fund.sol:Fund at 0xxxxx
for verification on the block explorer. Waiting for verification result...

Successfully verified contract Fund on the block explorer.
https://www.oklink.com/polygonAmoy/address/0xxxxx#code

Verifying proxy: 0xxxx
An unexpected error occurred:

Error: Etherscan API call failed with status 404, response: {"code":404,"msg":"","error_code":"404","error_message":"","detailMsg":"","data":{"timestamp":1713274695767,"status":404,"error":"Not Found","trace":"java.lang.NullPointerException: Cannot invoke \"String.toLowerCase()\" because the return value of \"java.util.Map.get(Object)\" is null\n\tat com.okcoin.blockchain.rest.server.pri.chain.service.impl.VerifyContractServiceImpl.contractVerifyAsyncForHardhat$original$zGstDNF6(VerifyContractServiceImpl.java:2939)\n\tat com.okcoin.blockchain.rest.server.pri.chain.service.impl.VerifyContractServiceImpl.c

I also tried to verify manually through the interface but nothing worked

The issue is with: ERC1967Proxy

1 Like

Hello,

I have the same problem, the implementation is verified without any problem but my proxy cannot be verified,

That error looks like it is coming from the oklink block explorer's API.

Can you try verifying manually using the Solc JSON input from How to verify a contract on Etherscan/BscScan/PolygonScan , or share your ERC1967Proxy address and the implementation address that you are using?